Exporting/Importing data from/to Mobility Lab

Overview

Mobility Lab provides the ability to export your data in a number of formats. This can be useful if you are performing any further analysis of your recordings, or need a way to save or share results beyond the visualizations available in Mobility Lab. Mobility Lab also provides the capability to import exported data into another workspace. This can be useful for backup/recovery, merging data collected on multiple systems, and related tasks.

Export Scope

You can specify the trials you wish to export in several ways:

  • Export all trials in the current subject group by clicking on the name of your subject group in the top right corner and choosing the "Export" option.
  • Export all trials in the current subject by clicking on the cog icon in the top right corner of the Subjects panel and choosing the "Export" option.
  • Export a single trial by clicking on the cog icon in the top right corner of a trial's report view and choosing the "Export" option

Filtering which trials are exported

From within the export dialog of the first two options above, you will additionally be able to filter the trials which are exported. The filter options include:

  • The sequence type. Only trials that fall within the selected sequence will be exported.
  • The test type. Only trails of the selected test type will be exported.
  • The test condition. Only trials of the specified test/condition will be exported.
  • Start date/time. Trials recorded before the start date/time will be excluded from the export.
  • End date/time. Trials recorded before the end date/time will be excluded from the export.

Export Options

There are 5 different export options available within Mobility Lab. These are:

  • Summary analysis results (CSV format). These exports are in CSV (comma separated value) format, which can be read from any spreadsheet application or parsed by many scientific computing applications. A single summary CSV export includes results from only a single test type. For example, if you export 40 trials where 25 are Sway trials and 15 are Walk trials, you would have 2 summary CSV files -- one for all the Sway trials and one for all the Walk trials. Each row of this export represent the analysis results for one trial. The first 8-10 column represent the metadata about the trial (e.g., subject ID, trial date/time). The remaining rows include the analysis results, where each row is a single metric. For trials where there are repeated values for a single metric (e.g., for a Walk trial with 20 gait cycles detected, there are 20 "Stride Length" metrics), the average and standard deviation of the metric is reported. These files also include the mean and standard deviation of our normative dataset in the top rows (when normative data is available). Attached to this knowledge base article is a PDF document defining each of the metrics that Mobility Lab computes.
  • Detailed analysis results (CSV format). A single detailed CSV export documents the results from a single trial. For example, if you export 40 trials, where 25 are Sway trials and 15 are Walk trials, you would have 40 detailed CSV files. Attached to this knowlege base article is a PDF document that annotates a detailed CSV export. This detailed format includes the following, additional differences relative to the summary export:
    • Multiple values for repeated metrics. Using the same example as above, a Walk trial with 20 gait cycles would include 20 values for the "Stride Length" metric.
    • Event timing. Some test types also compute the timing of certain events. For example, the export of a Walk trial includes the timing of every toe-off event.
    • Annotations. If you annotate your trial during the recording, the annotation events (name and time) will be present in the detailed CSV export.
  • Metadata (XML format). Regardless of how many trials your exported, one XML file will be generated that describes the metadata for all of the exported trials. This information is largely redundant with what is provided in the metadata fields in the CSV exports, but is in a format that can be re-imported into Mobility Lab. If you are exporting data with the goal of re-importing it into another Mobility Lab system or workspace, this option and the "Raw inertial data" option must both be selected.
  • Raw inertial data (HDF format). These are the actual recordings that were made for the exported trials. Each trial results in one such recording, and each of these recordings will contain the data from all Opals that were configured at the time of the recording.
  • Compress export into a single zip file. When selecting this option, all of the exported files will be compressed into a single zip file.

Export Format Structure

Data is exporting in the following format

  • [export_folder] This folder is dynamically created within the folder you select for export. The folder name will embed the current data/time of the export
    • Summary and detailed CSV files (if options are selected) 
    • XML metadata file (if option is selected)
    • [rawData] This is a subfolder of the export_folder
      • HDF files (if option is selected)

If the "Compress export..." option is selected, this folder structure will be contained within the resulting ZIP archive.

Incremental Backup

Incremental backup provides a way to export your data incrementally, such that only newly collected data needs to be backed up each time. This saves time and disk space.

If you are performing incremental backups of your workspace (Tools->"Incremental Backup")

  • The folder you select is used as the [export_folder] in the structure above. Basically, a new subfolder is not created each time you perform an incremental backup.
  • The XML and HFD options are automatically selected for the export.
  • The export folder is not compressed after the export is complete.
  • Each time the incremental backup is performed:
    • A new timestamped XML file is generated which describes your entire data set. These can, in a way, be considered snapshots of your data set at these points in time. You could restore from any of these snapshots.
    • Any HDF files that are not yet backed up to the incremental backup folder's rawData subfolder are copied over.

Importing Data

  • Importing data requires that you have both the raw data (Hdf, *.h5), and metadata (XML, *.xml). When both the XML and HDF options are selected, they will be exported to a folder with the following format:
  • To start the import process, click on Tools->"Import Data"
  • Select the XML file from the export_folder. The import process will expect to find a subfolder named "rawData" at the same location as this XML file.
  • Warnings/Errors. The import process will perform an analysis of the import file and will provide feedback prior to starting the import process. Warnings/errors may include:
    • You may be prompted to select a subject prior to the import if you exported trials without subject information (e.g., if you exported a trial from its report). In this case, you must first select the subject you wish to import the trial into.
    • If you are importing a study or subject that already exists in your target workspace, you will be asked how you want to handle the import (rename, merge, or skip)
    • If you are importing any trials that are missing their HDF files in the "rawData" folder, you will be alerted. You can continue to import the metadata only, but there will be no data available for analysis.
  • Import Summary. Prior to performing the import, you will be informed about which data will be imported into your workspace. For example, the total number of subjects, trials, etc.

Restoring from an Incremental Backup

The suggested way to perform an restore from an incremental backup is to:

  • Create a new workspace through the File->"Switch Workspace" tool
  • When the "Create a new Subject Group" dialog comes up, choose the "Import" option at the bottom of the dialog.
  • Select the XML file you wish to restore from within your incremental backup directory.
Have more questions? Submit a request

0 Comments

Article is closed for comments.